Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vimarun fails to start Workstation or VM when WOL is used
Hi Folks:

     I have been evaluating Vimarun for a few days and had one issue resolved by setting the service to Delayed Start, however I have been testing it with the Wake on Lan feature which does start the computer after it is powered off, but then Vimarun fails to start VMware workstation or the VM I have selected for auto start in Vimarun.

    I have tried the following sequences:
          1) Manually start VMware workstation then power up VM; do a "reboot" command to windows on the Host system; 

                     Windows shuts down, the system does the normal motherboard post and restarts Windows and Vimarun starts VMware workstation and restores
                      the VM that was powered on;

           2) Manually power off the running VM and then close VMware workstation; do a "reboot" command to windows on the Host system;

                      Everything works the same as in test (1) above;

           3) Manually start VMware workstation then power up VM; do a system shutdown -i.e. windows power off command on the host system;

                       Powering on the system by hitting the start button on the system or using the WOL feature of the network card results in the system
                       doing the normal motherboard post and restarts windows on the host system - however Vimarun fails to start VMware workstation and
                        restore the VM;

      I have attached the log files from Programdata/vimarun/systemlogs below
.txt   VimarunLauncher.txt (Size: 12.52 KB / Downloads: 1)
.txt   VimarunService.txt (Size: 30.99 KB / Downloads: 1)       

     Just wondering if anyone has run into this and whether they can suggest a solution.

Best regards, Dave Melnyk
Hello Dave,

I checked your supplied logs and in them VMware reports each time that a VM is running on startup.
Also it looks like that each shutdown is followed by a startup along with a VM startup. The only time it didn't happen is the boot at 2022-01-30 around 16:13, but that's because you login immediately so it is picked up by the vimarunLauncher instead.

It is certainly possible that I am overlooking something. FWIW, I do not really expect vimarun to work differently when starting via WOL, sadly there's nothing in the logs right now for seeing how you started your host. So I would at least need the time of shutdown/startup in order to be able to correlate.

I'm wondering though, is it possible that it is not an actual shutdown, but a windows suspend/sleep at the host when using the power off?
That might explain what you are seeing here as then Windows doesn't close all applications and instead continues where it was on waking up.

PROBLEM SOLVED! (sort of...)

Hi Wil:

      Thanks for the quick reply - I believe I have found the problem - it is related to Windows 10 "Fast startup".

     Apparently when enabled it causes windows to create a "small" partial hibernation file that Windows uses on start up - it obviously is listing a VM as "running" when it actually is not running! Here is a link to an article that explains the issue. I was tipped by some info on using WOL where this Windows setting can "sometimes" cause difficulties. 

           How to disable Windows 10 fast startup (and why you'd want to) | Windows Central

     With Fast startup disabled in windows 10, everything works properly with Vimarun - unfortunately with it disabled the Wake On Lan ability also seems to get disabled somehow! This might be because of  my hardware, but it works correctly when Fast Startup is enabled in Windows. Will have to test on my other server which is using more recent hardware. I would guess that the "small" hibernation file that is getting written happens before windows gets signalled that the VM is no longer running so provides incorrect info to Vimarun on a restart. Not sure why this isn't the case on a simple "restart" command.

Regards, Dave Melnyk
Further update:

Managed to get the Wake-on-Lan feature running with Fast startup disabled and every works well with Vimarun. So all is good! (a few tricky settings in Windows that were not
necessarily as obvious as they could have been!)

Thanks for the help and quick responses!

Cheers, Dave Melnyk
Hi Dave,

Glad to hear that you got past that.
Sorry for not responding, it is currently on my list to investigate a bit to see what is possible in this area.
But haven't had the time yet, it's a busy day so far.

FYI, you should now be able to directly attach log files without having to rename the file extension to .txt
Yes I noticed you had needed to rename the files. Wink

Forum Jump:

Users browsing this thread: 1 Guest(s)