Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VM not starting automatically
I have added a VM to the list for AutoStart with background as the option. However, when I reboot windows, the VM does not start. I have to logon then manually start with vimarun or restart the vimarun windows service. I even tried setting the service to Automatic (Delayed) but still it will not automatically start with a reboot. When I set the option to Foreground, the VM also does not start even when I login unless I restart the service or manually start with the tool. I am assuming that the tool will start the VM, even if I am not logged on to the system. The main goal is to make sure the VM start when Windows updates or power is restored..

The next update of Vimarun will do the same like you did manually (change the autostart service to automatic delayed).
My guess would be that the service is not installed as the user running, but then you should have seen an error during installation, so that is at least a bit confusing.
Have you tried re-installing?

If that doesn't help, can you please email me the support bundle?
You can create a support bundle from the help menu. Doing so creates a zip file on your desktop which you can then email to

I found in the vix logs c:\users\<user>\AppData\Local\Temp\vmware-<user> the following...

Basic issue is that VIX can’t start the VM in the background… It keeps logging this in an endless loop..

2021-09-15T18:16:44.154-05:00| vix-poll| I005+ Cannot open the disk 'X:\VM\server\server_disk-000001.vmdk' or one of the snapshot disks it depends on.
2021-09-15T18:16:44.154-05:00| vix-poll| I005+ Module 'Disk' power on failed.
2021-09-15T18:16:44.154-05:00| vix-poll| I005+ Failed to start the virtual machine.

After doing a lot more research I have concluded that this is because the snapshot mentioned in the logs is tied to a backups volume on a removable drive mounted to the host system. The removable drive is a usb-c connected RAID 1 M2 SATA drive with Bitlocker Enabled. Apparently Windows 10 does not allow DMA access to removable drives at startup any longer when Bitlocker is enabled. There are multiple group policies related to this setting but I had no luck bypassing the DMA protections. From what I can tell, it requires a combination of system firmware and OS settings for some of these group policy setting to work. In addition, the setting is designed to prevent someone from bypassing drive encryption or obtaining encryption key info. To work around, I set the OS to auto logon + added a logon script to lock the PC at startup. The PC boots, logs on as the user, then locks when the script runs… Providing < 1 sec of access to the desktop and no way to stop it. This provides VIX access to the drive allowing the service to start the VM in the background. I am sure this might present some small security risk but it allows the VM to start in the background which is the important requirement.

Forum Jump:

Users browsing this thread: 2 Guest(s)