Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Testing Vimalin - something is wrong
Good Morning,

First of all, excuse me for my English.

A few days ago I found a reference to Vimalim on the vmware website.
I started to read a little about the operation of the program and I really liked it, since I thought it was a simple but powerful program.

So I installed it on the host where I have my VM hosted.
The first tests worked in a correct way, but for a few days it has not worked too well.
It takes a long time to do the backups (the last 398 minutes) and I don't know why.

My host has the following characteristics:
Mac Pro (early 2009)
Processor: 2x3.46 GHz 6-Core Intel Xeon
Memory: 128GB 1333MHz DDR3

Only macOS Mojave is installed on the main HDD.
A Solid HDD is mounted in bay 2, where only the virtual machine is.
A 1TB mechanical HDD is mounted in bay 3, only to carry out backups.

MY VM is configured with:
6 processor cores.
16384 MB of memory.

For some reason the time it takes to make the backup is exorbitant and I would like to know if it can work faster before buying the paid version.

Thank you.

Your English is fine Smile
I think we already chatted on twitter?

Like I said on twitter, this certainly is not expected performance. Vimalin does its work in the background as it is designed to not disturb any running virtual machines, so it doesn't try to copy at an increased priority. On macOS the copy process literally uses the /bin/cp command for all the files it copies.
If you would copy the VM from the command line, then it should take about the same amount of time.
Note though that Vimalin does extra things like that it hashes all files it copies, so that it can guarantee the files are OK when restoring, so it is not unexpected to be a bit slower, but not that much slower. It also uses VMware snapshot technology (create/commit snapshots) when the VM is running so that it can copy the VM's files.

The config of your VM sounds fine.
Can you please email me the support bundle?
Based on that I can give better tips on what to change or see why it is taking so long.
You can create a support bundle from the help menu -> Create Support Bundle.
That should place a .gz file on your desktop which you can then email to and I will take a look at it.

Hello Wila,

Yes! We were talking through twitter, but it is very difficult to express everything in 140 characters. Haha
Now I send the support Bundle to your email to see if it is possible to know what the problem is, since everything seems to be correct.

Thank you!
This has been resolved.

There have been 2 changes.
First one was to change the virtual disk from a single file to a split disk. That helps making it easier for the backup snapshots to be made and commit once the backup is done.

That however did not fix the time it took to commit a snapshot.
As it is the VM's lived on an exfat partition and exfat on macOS does sometimes behave weirdly. I suggested to change the filesystem to HFS+ and now instead of hours it now takes seconds to commit a snapshot.


Forum Jump:

Users browsing this thread: 1 Guest(s)