Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error on scheduled backup
Running win10 home version 1803. Workstation pro version 10.
I did 2 manual backups and both worked.

Started a scheduled weekly backup on the XP VM which was running at the time and encountered an error:

"failed copying files, Winxp.vmx"
"OK committing snapshot"
"failed completed failed, unable to copy all files"

Where is the log kept in case you need the entire thing?

I notice the vimalin service and shared vm manager are running even when vimalin is closed.
Can these services be stopped and restarted as needed?
Are they used if doing a manual backup?

The location of the logs depends a bit on the Windows version used, but if your Windows host is recent then it should be:

The Vimalin Service and Shared VM Manager are needed for the automation and communication with VMware Workstation.
Without those running there will be no backups.
The GUI itself does not run any of the backups, manual or automated.

If you want you can send me an email with the support bundle at and I will have a look at why you got that error.
You can make a support bundle from the home page, menu -> Help -> Create Support Bundle

edit: FWIW, it looks like that Vimalin is complaining about not being able to copy the .vmx file. I need to see full support bundle details to get a better understanding of the details. At this moment I can come up with a few reasons, but the log helps in isolating those reasons, so please email the bundle.

Support bundle emailed.
When inspecting the log file it became clear that Vimalin tried to backup a .vmx~ lock file.
The file was there when it enumerated the VM folder, but gone at the time it tried to backup that file. Of course it makes no sense to backup a lock file.
To be frank I have not seen these type of lock files recently, it might be a VMware Workstation 10.x difference.

Either way, this has now been addressed. Vimalin no longer tries to backup .vmx~ files.

You can download the latest version either via File -> Check for Updates, or via the main website.

Then uninstall the old version. If the uninstaller asks to reboot after uninstalling then please reboot as otherwise your install will be broken, most of the times a reboot is not asked though.
After that you can install the new version.


Forum Jump:

Users browsing this thread: 1 Guest(s)