Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VMWare Disk size error after backup?
I installed Vimalin for the Mac and tried a backup. My VMWare bundle is 162 GB and there was plenty of room on my external backup drive and I had about 150 GB available on the Mac hard drive. However, the backup failed after 71 minutes for unknown reasons. VMWare had been running, but it went into error mode after the failed backup with a forced Windows 10 reboot. Once it recovered, everything seemed fine.

To try to fix this, I spent some time freeing disk space on my internal hard drive, assuming the .vmdk files have to be written there first. There's now Vimalin successfully made my first backup after about an hour and I'm left with nearly 100 GB of .vmdk files in the VMWare bundle on the Mac in dozens of files - some new and some old (is there a safe way to delete some of those?).

Since then, I am getting warnings from VMWare that the disk where VMWare is stored is full and I need to free up ~200 MB of space, forcing me to shut the program down. This has happened several times even though it looks like there's plenty of space. This doesn't seem normal and I'm wondering if Vimalin rearranged something in the VMWare bundle.

Does anyone have advice here? Is direct tech support available? Thanks.

Hi Rick,

Vimalin does not write directly to the VM bundle, nor does it make a copy to the local disk first.
If the VM was running then it does make a snapshot before copying the data out.

Under no circumstance should you start deleting files from the virtual machine bundle as that will very likely end up in corrupting your VM.
You can check under snapshot manager (menu Virtual Machine -> snapshot -> snapshot) if there's an open snapshot.
You mention it is a Windows VM, so first step in trying to get more free space is:
- shut down the VM
- go to menu "Virtual Machines" -> Settings -> General -> there's a button "Clean up virtual machine"
That hopefully gives you a few more GB free space.
After that you can try and delete old snapshots (assuming there's a left over snapshot)

If you still have problems after that then please create a support bundle from the Vimalin menu -> Help -> Create Support Bundle and email it to and I will take a look.

I tried cleaning up the VM in the General preferences pane - it was reporting on the Virtual Disk-s002.vmdk file rather than the primary Windows file, but the program seemed to handle the issues. The Virtual Disk.vmdk file now has 60 GB of space in the Hard Disk pane and Windows shows a disk size of 54.9 GB. After the cleanup there are only 17 .vmdk files in the bundle totaling about 60 GB and VMWare/Windows 10 started normally. I selected 'automatic cleanup' to avoid this problem moving forward.

The total Windows bundle is now only 76 GB, so I guess the problem is solved! I'll do a second backup with this smaller file today. Thanks.
Thanks Wil - I actually did most of that as reported above before I saw your response, although I don't have any snapshots (never seemed to work well in the past). I'll let you know if there are further problems. All of my critical docs are stored on the Mac, so a corrupted Windows disk is frustrating but not a huge problem if I have to reinstall someday.

As a long-term Mac user (since the first one came out in 1980!), my Windows knowledge is limited. I'm not the most fastidious VMWare user and usually only deal with problems like disk size when they occur! Maybe activating the auto-cleanup will keep me out of trouble. Wink You may want to add a FAQ about the importance of cleaning things up before backup.

Forum Jump:

Users browsing this thread: 1 Guest(s)